slackware.ru
http://www.slackware.ru/forum/

Про новый GIMP 2.10.0 и его зависимости
http://www.slackware.ru/forum/viewtopic.php?f=32&t=2294
Страница 1 из 1

Автор:  saahriktu [ 01 май 2018 23:55 ]
Заголовок сообщения:  Про новый GIMP 2.10.0 и его зависимости

Не так давно вышел новый GIMP 2.10.0. В стабильной Slackware 14.2 он собираться не будет из за зависимостей, как минимум, этих:
Код:
  - Error: missing dependency babl >= 0.1.46
  - Error: missing dependency gegl-0.4 >= 0.4.0
  - Error: missing dependency glib >= 2.54.2
      *** Test for GLIB failed
  - Error: missing dependency fontconfig >= 2.12.4
  - Error: missing dependency gexiv2 >= 0.10.6
  - Error: missing dependency libmypaint >= 1.3.0
  - Error: missing dependency mypaint-brushes-1.0
  - Error: missing dependency lcms2 >= 2.8

И -current пока ещё не соответствует этим требованиям. На данный момент в -current gegl версии 0.2.0, а gexiv2, libmypaint и mypaint-brushes отсутствуют в базовой системе совсем.

Автор:  saahriktu [ 02 май 2018 10:21 ]
Заголовок сообщения:  Re: Про новый GIMP 2.10.0 и его зависимости

Похоже, что даже в Arch'е версия gegl является препятствием для обновления GIMP'а (0.4.0 там пока ещё в Staging). Вчера вышла 28-я Fedora, там тоже пока ещё GIMP 2.8.22. GIMP 2.10.0 в Fedora Rawhide и будет в следующем релизе Fedora 29.

По данным distrowatch'а GIMP 2.10.0 добрался также до разрабатываемых веток Debian'а, Mageia'и и Devuan'а.

Автор:  saahriktu [ 02 май 2018 10:30 ]
Заголовок сообщения:  Re: Про новый GIMP 2.10.0 и его зависимости

О, уже:
Код:
l/gegl-0.4.0-x86_64-1.txz:  Upgraded.
l/gexiv2-0.10.8-x86_64-1.txz:  Added.
  Required by gimp-2.10.0.
l/json-c-0.13.1_20180305-x86_64-1.txz:  Added.
  Looks like we're getting this package back since libmypaint needs it.
l/json-glib-1.4.2-x86_64-1.txz:  Added.
  Required by gegl-0.4.0 and gimp-2.10.0.
...
x/libmypaint-1.3.0-x86_64-1.txz:  Added.
  Required by gimp-2.10.0.
x/mypaint-brushes-1.3.0-noarch-1.txz:  Added.
  Required by gimp-2.10.0.
xap/gimp-2.10.0-x86_64-1.txz:  Upgraded.

ftp://ftp.osuosl.org/pub/slackware/slackware64-current/ChangeLog.txt

Автор:  bormant [ 02 май 2018 18:44 ]
Заголовок сообщения:  Re: Про новый GIMP 2.10.0 и его зависимости

Для 14.2 собрал успешно, подняв версии необходимых компонентов слакбилдами из current (только предварительно нужно не забыть закомментировать в них удаление *.la).

Автор:  saahriktu [ 04 май 2018 23:23 ]
Заголовок сообщения:  Re: Про новый GIMP 2.10.0 и его зависимости

Для 14.2 собрал успешно, подняв версии необходимых компонентов слакбилдами из current (только предварительно нужно не забыть закомментировать в них удаление *.la).

Ну, так-то, конечно, можно. Только, вот, называть такую систему можно уже по-разному. Я такое классифицирую уже как 14.2+. 14.2 - это когда пакеты базовой системы либо соответствуют версиям на момент релиза, либо, максимум, версиям официальных обновлений стабильного релиза (из директории patches).

Автор:  bormant [ 05 май 2018 09:19 ]
Заголовок сообщения:  Re: Про новый GIMP 2.10.0 и его зависимости

Всё время относился к этому по-другому.
Конкретный выпуск -- это вариант распространения.
Система -- это инструмент для решения собственных задач. Если для этого нужно что-то заменить в разумных объемах -- это не является проблемой.
Другое дело, когда желаемое изменение тянет за собой полсистемы и больше -- закат солнца вручную дело, безусловно, великое, но по возможности лучше обойтись чем-то менее масштабным ;)

Автор:  puyamolina [ 29 окт 2018 03:33 ]
Заголовок сообщения:  Re: Про новый GIMP 2.10.0 и его зависимости

Здравствуйте, товарищи)

Ставлю gimp. Сначала установил зависимости, потом при сборке выдаёт вот это:

Код:
/bin/sed: can't read /usr/lib64/libfontconfig.la: No such file or directory
libtool:   error: '/usr/lib64/libfontconfig.la' is not a valid libtool archive
Makefile:813: ошибка выполнения рецепта для цели «libgimpconfig-2.0.la»
make[2]: *** [libgimpconfig-2.0.la] Ошибка 1
make[2]: выход из каталога «/tmp/gimp-2.10.6/libgimpconfig»
Makefile:848: ошибка выполнения рецепта для цели «all-recursive»
make[1]: *** [all-recursive] Ошибка 1
make[1]: выход из каталога «/tmp/gimp-2.10.6»
Makefile:749: ошибка выполнения рецепта для цели «all»
make: *** [all] Ошибка 2


Как я понимаю, оно хочет /usr/lib64/libfontconfig.la. А где ж я ему его возьму? :( Подскажите пожалуйста, что можно сделать?

Автор:  nk [ 29 окт 2018 04:23 ]
Заголовок сообщения:  Re: Про новый GIMP 2.10.0 и его зависимости

а пакет fontconfig стоит? потому что вот:
Код:
> grep libfontconfig.la /var/log/packages/*
/var/log/packages/fontconfig-2.11.1-i486-2:usr/lib/libfontconfig.la

Автор:  bormant [ 29 окт 2018 09:06 ]
Заголовок сообщения:  Re: Про новый GIMP 2.10.0 и его зависимости

Есть у меня подозрение, что взяли или собранный пакет из current или собрали слакбилдом из current.

В current отказались от.la полностью (ценой пересборки вообще всего, на минуточку), ибо никакой пользы окромя вреда от них нет. Поэтому, если берете для 14.2 слакбилд из current-14.2+, можно внутри закомментировать удаление .la файлов.
А бинарные пакеты из current брать для stable -- моветон.

Автор:  sunjob [ 31 мар 2019 00:50 ]
Заголовок сообщения:  Re: Про новый GIMP 2.10.0 и его зависимости

to bormant

можно более расширено, про эти самые :
Код:
14.2 *.la - наше все
и
Код:
14.2 cur *.la - фу-кака

Страница 1 из 1 Часовой пояс: UTC + 3 часа
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/