slackware.ru
http://www.slackware.ru/forum/

viber перестал работать
http://www.slackware.ru/forum/viewtopic.php?f=32&t=1811
Страница 1 из 1

Автор:  oldradio77 [ 30 апр 2016 16:46 ]
Заголовок сообщения:  viber перестал работать

связано с обновлением версии, слакбилда для новой нет.
Вытащил deb распаковал, теперь стал требовать pulseaudio, обхожу через apulse, не заводится:

bash-4.2$ apulse /opt/viber/Viber
/opt/viber/Viber: /usr/lib64/libcurl.so.4: no version information available (required by /opt/viber/Viber)
This application failed to start because it could not find or load the Qt platform plugin "xcb".

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, wayland-egl, wayland, xcb.

З.Ы. 14.1 multilib

Автор:  LamerOK [ 08 май 2016 23:25 ]
Заголовок сообщения:  Re: viber перестал работать

Устанавливай QT5, а заодно и Python Qt5. Мне помогло на раз-два

Автор:  oldradio77 [ 26 май 2016 17:08 ]
Заголовок сообщения:  Re: viber перестал работать

не помогает

Автор:  cdrw [ 06 июн 2016 17:24 ]
Заголовок сообщения:  Re: viber перестал работать

Цитата:
This application failed to start because it could not find or load the Qt platform plugin "xcb".


Требует пакет libxkbcommon для QT-5.
Пакет можно взять у alien:
http://slackware.uk/people/alien-kde/cu ... 1alien.txz

Автор:  cdrw [ 06 июн 2016 17:52 ]
Заголовок сообщения:  Re: viber перестал работать

Я тоже сталкивался с такой ошибкой. Началось с того, что я задумал опакетить программу "cloud" для сервиза "облако.майл.ру". Пакет потребовал наличия QT5. Я его установил из репозитория от alien. Затем последовало сообщение об ошибке как ваше. Ответ я нашёл у того же alien

Цитата:
Comment from alienbob
Posted: February 6, 2016 at 22:35

414n, you can simply install the libxcbcommon package from my KDE5 repository to fix your present issue.
I’ll have to see if I am happy with this unexpected new dependency for the qt5 package which apparently got picked up when I rebuilt Qt5 with that installed on the system.


А вот viber после cloud установился уже без проблем...
Скрипты для создания этих пакетов прилагаю.

Автор:  flank1er [ 07 июн 2016 06:40 ]
Заголовок сообщения:  Re: viber перестал работать

Цитата:
>/opt/viber/Viber: /usr/lib64/libcurl.so.4: no version information available (required by /opt/viber/Viber)

slackware64-current, viber-6.x.x
да, тоже было такое. решил установкой вайбера прошлогодненго разлива 4.2.2.
работает.

Автор:  oldradio77 [ 04 июл 2016 12:55 ]
Заголовок сообщения:  Re: viber перестал работать

на 14.2 заработал без вопросов

Автор:  nk [ 29 янв 2017 05:36 ]
Заголовок сообщения:  Re: viber перестал работать

на slackware64-14.2 была аналогична ошибка с xcb для приложений qt5, после
Код:
Upgrading qt5-5.7.0-x86_64-3alien package using ./qt5-5.7.1-x86_64-1alien.txz
вышел на эту тему, начал искать что же надо, очень помогла вот эта тема http://stackoverflow.com/a/39725335 и команда оттуда:
Код:
$ QT_DEBUG_PLUGINS=1 cloud
...
Got keys from plugin meta data ("xcb")
QFactoryLoader::QFactoryLoader() checking directory path "/opt/mail.ru-cloud/platforms" ...
Cannot load library /usr/lib64/qt5/plugins/platforms/libqxcb.so: (libwacom.so.2: невозможно открыть разделяемый объектный файл: Нет такого файла или каталога)
QLibraryPrivate::loadPlugin failed on "/usr/lib64/qt5/plugins/platforms/libqxcb.so" : "Cannot load library /usr/lib64/qt5/plugins/platforms/libqxcb.so: (libwacom.so.2: невозможно открыть разделяемый объектный файл: Нет такого файла или каталога)"

так что теперь к установки qt5 из репозитория Alien http://bear.alienbase.nl/mirrors/people ... .2/x86_64/
Код:
# slackpkg install "qt5-5 qt5-webkit libinput libxkbcommon "
поставил вот это
Код:
# slackpkg install "libwacom "
и все запустилось

Автор:  AlexMak [ 31 окт 2017 11:37 ]
Заголовок сообщения:  Re: viber перестал работать

Подскажите где скачать сабж для x86 14.1

Страница 1 из 1 Часовой пояс: UTC + 3 часа
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/