slackware.ru
http://www.slackware.ru/forum/

Полоса посреди экрана при просмотре видео
http://www.slackware.ru/forum/viewtopic.php?f=27&t=1134
Страница 1 из 1

Автор:  burn [ 15 фев 2014 02:56 ]
Заголовок сообщения:  Полоса посреди экрана при просмотре видео

Всем привет, с вами НЕ Джонни Ноксвил, и сегодня мы попытаемся разобраться с проблемой воспроизведения видео на ноуте с интегрированной графикой :-):

исходные данные: Core i3-2328, HD-3000, 4GB RAM, драйвер xf86-video-intel 2.21.15, mesa 9.1.7

при воспроизведении видео с высоким битрэйтом возникает эффект, эээ, не знаю даже как его описать :du_ma_et: приложу фотку экрана, так как на скриншотах данный эффект не проявляется.

Изображение

сначала грешил на плеер, пользовался mplayer'ом, поставляемым в составе дистрибутива. Решил, что дело в выключенном аппаратном ускорении, начал гуглить эту тему, наткнулся на такую штуку - vaapi, прочитал, что mplayer его не поддерживает, но есть патч. собрал с патчем, ничего не изменилось (хотя нет, изменилось, раньше ещё и mkv'шки тормозили, притом жутко; в собранном mplayer'е появилось новое устройство вывода - vaapi, при его использовании mkv перестали тормозить, но только из консоли, в smplayr'е не смотря на явно установленное устройство вывода, тормоза остались).

опечалился, начал гуглить дальше, нашёл форк mplayer'а под названием mpv (точнее сборная ссср из двух проектов, mplayer и mplayer2 - форк первого), собрал, затестил. к этому времени нагуглил, что аппаратное ускорение и так задействуется, и его специальное включение не требуется. и действительно, в mpv матрёшки не тормозили при любом устройстве вывода, если включить отладочный вывод (-v, или -vv, или ещё больше v), то из него можно заключить, что аппаратное ускорение работает. но не в mplayer'е, видимо, какая-то бага...

возрадовался! думал, что дело в шляпе. усиленно начал смотреть фильмы, и увидел, что проблема как была, так и осталась - полоса посреди экрана никуда не делась. какой-либо зависимости между форматом/кодеком, размером, разрешением видео, текущей нагрузкой на процессор, диск, используемой ФС (фильмы храню на ntfs-разделе, иногда кидали их и на родной ext4) не усмотрел. иногда смотришь - весь фильм полоса так и не появляется, иногда - постоянно.

так ничего и не добился, может умудрённые опытом форумчане чего толкового подскажут?

Автор:  flank1er [ 15 фев 2014 07:23 ]
Заголовок сообщения:  Re: Полоса посреди экрана при просмотре видео

это называется "вертикальная синхронизация".
вернее ее отсутствие.

Автор:  yars [ 15 фев 2014 09:10 ]
Заголовок сообщения:  Re: Полоса посреди экрана при просмотре видео

Цитата:
это называется "вертикальная синхронизация".

А опция, соответственно, sync-to-vblank, точно? Не путаю?

Автор:  flank1er [ 15 фев 2014 09:49 ]
Заголовок сообщения:  Re: Полоса посреди экрана при просмотре видео

vsync вроде.
vblank это гасящий импульс, обратный ход луча развертки

Автор:  VitXXX [ 22 июн 2015 17:55 ]
Заголовок сообщения:  Re: Полоса посреди экрана при просмотре видео

Такое бывает при отсутствии драйверов на видео.........
У меня было такое на радеон 9200 :)
Я вообще не понял как ставить драйвера на интел видео....

Автор:  yars [ 22 июн 2015 19:55 ]
Заголовок сообщения:  Re: Полоса посреди экрана при просмотре видео

VitXXX, не, на видео от Intel ничего дополнительно ставить и не надо, оно уже и так есть в ядре и в пакетах x/xf86-video-intel и x/mesa.
P.S. Проблема, полагаю, уже неактуальна ;)

Страница 1 из 1 Часовой пояс: UTC + 3 часа
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/